Produtividade

Por Paulo Alves, para o TechTudo


É possível numerar linhas e colunas no Excel automaticamente utilizando fórmulas. Por meio de alguns comandos fáceis, o usuário pode adicionar números sequencialmente na planilha para organizar itens de maneira crescente sem precisar incluir os algarismos célula por célula. A função é útil, por exemplo, para criar listas e relações em geral que precisam de numeração, seja para identificar itens ou apenas deixar a tabela mais organizada. Veja, a seguir, como numerar linhas e colunas no Excel pelo PC.

Aprenda a numerar linhas e colunas no Excel — Foto: Paulo Alves/TechTudo

Quer comprar celular, TV e outros produtos com desconto? Conheça o Compare TechTudo

Como numerar linhas no Excel

1. Utilizando o preenchimento automático

A maneira mais rápida de numerar uma linha no Excel é por meio da função de autocompletar do programa. Essa é a alternativa mais rápida para quem precisa de uma lista sequencial comum.

Passo 1. Marque a célula onde a contagem irá começar e digite o número inicial da sequência, como o número 1;

Adicione o número que iniciará a sequência — Foto: Reprodução/Paulo Alves

Passo 2. Depois, digite na linha célula abaixo o segundo número da sequência, como o número 2.

Adicione o segundo número da sequência — Foto: Reprodução/Paulo Alves

Passo 3. Para criar uma planilha com linhas numeradas automaticamente, marque as duas células e arraste para baixo utilizando a alça de preenchimento;

Selecione as duas células e arraste para baixo puxando pela alça de preenchimento — Foto: Reprodução/Paulo Alves

Passo 4. Leve até a célula onde a numeração deve terminar. A numeração será preenchida automaticamente seguindo a mesma sequência.

Arraste e solte para numerar as linhas automaticamente — Foto: Reprodução/Paulo Alves

2. Utilizando fórmula

Além disso, é possível numerar linhas no Excel utilizando fórmulas. A solução é útil para, por exemplo, criar numeração com formatação personalizada.

Passo 1. Clique sobre a célula inicial e digite a fórmula a seguir substituindo o que vai entre aspas pela formatação desejada para a numeração. Além disso, lembre-se de indicar dentro dos parênteses a célula de onde a contagem será iniciada.

=TEXTO(LIN(A1),"000-000")

Use as funções TEXTO e LIN combinadas para criar numeração personalizada — Foto: Reprodução/Paulo Alves

Passo 2. Use a alça de preenchimento para arrastar a fórmula para as demais células e preencher a sequência automaticamente.

Arraste para preencher as células com a numeração personalizada — Foto: Reprodução/Paulo Alves

Como numerar colunas no Excel

1. Utilizando o preenchimento automático

No caso das colunas, vale a mesma regra anterior: use o preenchimento automático para criar listas sequenciais comuns. Digite o número inicial em uma célula e o segundo na seguinte e arraste para o lado usando a alça para preencher tudo de uma vez.

Preencha as duas primeiras colunas e arraste pela alça de preenchimento para numerar — Foto: Reprodução/Paulo Alves

Veja também: como criar gráficos no Microsoft Excel

Como criar gráficos no Microsoft Excel

Como criar gráficos no Microsoft Excel

2. Utilizando fórmula

Assim como nas linhas, é possível usar uma fórmula para criar numeração personalizada para colunas. A função, no entanto, muda da LIN para a COL.

Passo 1. Digite a fórmula a seguir na célula que irá iniciar a contagem de colunas. Indique no parêntese qual é a célula e digite entre parênteses o formato de numeração que deseja utilizar.

=TEXTO(COL(A1),"000-000")

Utilize as funções TEXTO e COL combinadas para criar numeração personalizada para colunas — Foto: Reprodução/Paulo Alves

Passo 2. Em seguida, clique sobre a alça de preenchimento e arraste para o lado para preencher as células vizinhas de uma só vez.

Arraste para os lados para estender a numeração personalizada para as demais colunas — Foto: Reprodução/Paulo Alves

Via Microsoft

Mais do TechTudo